Q1:求通达信选股公式

DIF:="MACD.DIF";
DEA:="MACD.DEA";
A:=DIF<0 AND DEA<0;
B:=CROSS(DIF,DEA);
D:=C>O AND C>MA(C,5);
E:=MA(C,5)>=REF(MA(C,5),1);
XG:A AND B AND D AND E;

Q2:请将下面这个指标改成通达信4.17版本

该大智慧公式不适合改编为通达信使用。

Q3:如何用通达信公式去掉非st股。我想选出连续涨三天的ST与ST*股。

IF(INBLOCK('ST板块'),1,0) AND EVERY(C>REF(C,1),3);

Q4:请教高手,如何在通达信条件选股中加入排除如“银行类”“ST板块”“广东板块”等关联板块。谢谢

NOT(INBLOCK('银行类'));
NOT(INBLOCK('ST板块'));
NOT(INBLOCK('广东板块'));

Q5:老师们帮助把这个通达信的公式改编成选股公式,条件是黑马等于1.00,万分感激!

RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
VARA1:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VARA2:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VARA3:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VARA4:=(((VARA1 + (2 * VARA2)) + (3 * VARA3)) / 6);
VARA5:=MA(VARA4,3);
黑马:CROSS(J,0) AND (VARA5 <= (0 - 7));

Q6:老师们帮忙,把下面的通达信公式改写成选股公式,条件是黑马等于1.00,万分感激!

多空:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3);
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
VARA1:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VARA2:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VARA3:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VARA4:=(((VARA1 + (2 * VARA2)) + (3 * VARA3)) / 6);
VARA5:=MA(VARA4,3);
黑马:CROSS(J,0) AND (VARA5 <= (0 - 7));